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Intro tfo Android Development "

Why mobile?
* smartphones = "new thing”
* portable, powerful

Why Android? (over iI0S)
* Linux — Open Source
* Consumer-driven apps
* Hardware/software choice
* Google <3 Devs
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Hey, I'd love to do X with
my Android phone. Do you
- know if that's possible?

| &

Android

= Hmm, that's a good
question. I'm not really

BUTE.

\

©

@/

Well I've tried the major custom ROMs;
Modaco, CyanogenMod and OpenDesire now.
Man the control they give the user is amazing.
Unfortunately they still couldn't quite do it
how I wanted, so I'm signing up for App
Inventor; I'ma try to make it mysalf.

©

OK, so I've tried a few different apps
from the market that come close, but
none that quite do what I want. But I
read on a couple of forums that thera

are some customn ROMs that may allow

me to do it
@ O

e

Ok, so I've got my head around App Inventor,
and while I think it could do it, I don't think it's
the best way to implement this. S0 I've gotten
touch with a community of like-minded open
source programmers. I'm working to put
something together wih them, and I think if I
cut back on my hours at work a bit...
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Intro to Android Development

Overview . Y.,
* Java IR 7
* Eclipse M 2 sla s —5
* Hello World -
* Activity Cycle UUUULS J

* Try APl Demos

Stopwatch Example
Logcat/DDMS Debugging

Market Publishing and more...
Beats and Useful Resource Links
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Intro o Android Development

Android Java
* Linux, but apps in Java
* Dalvik Virtual Machine — DVM
* .apk format < Eclipse
* Standard java.” packages
* Custom graphics/Ul code
* NDK - C/C++ for ARM
(OpenGL ES 2.0, libraries, etc.)
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Intro to Android Development

Home Contacts Phone Browser e

APPLICATIONS \ ]

APPLICATION FRAMEWORK

Activity Manager ﬁ:i:g;:: FEE:' i:f:é srsif:m
Package Manager Tﬂ:ﬁg&? R;:::Er:f lﬁfﬂ:;z: Mﬁiﬂ;;gf )
LIBRARIES ANDROID RUNTIME
Surface Manager Fraﬂﬂirk SQLire Core Libraries
OpenGL | ES FreeType | YWebKit w
SGL 55L libe

LINUX KERNEL

Displa : Flash Memao Binder (IPC
ﬂriﬂer Camera Driver Diriver # DrivEer )

: T Audio Power
Keypad Driver WiF Driver Beirers Management
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Intro o Android Development

Eclipse
* FOSS, customizable, industry-standard
* Android-ready

Download these (if you haven't already)
* Eclipse Classic 3.6.1

* Android SDK R8 (get the .zip)
* Java SE Development Kit 6u23 (JDK)

* Code Samples used
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http://www.eclipse.org/downloads/packages/eclipse-classic-361/heliossr1
http://developer.android.com/sdk/index.html
http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.stwing.upenn.edu/~pengp/Files/PennApps/PennApps_AndroidStopwatch_src.zip

Intro to Android Development

Setup (Live Demo!)

* Install JDK (run installer)
* Extract Eclipse (e.g. C:/Android/eclipse)

* Install Android SDK
* Extract Android SDK (e.qg.

* Run SDK Manager

* Select packages
(only need Platform-tools, APl 9, document, and samples)

* Download and wait (long)

* Virtual Devices > New

* Name: “TestPhone2.3”, Target: Android 2.3 — API Level 9,
SD Card Size: 64 MiB

* Create AVD > Start... > Launch

* A virtual Android 2.3 phone for testing! Yay \o/
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file:///C:/Android/eclipse
file:///C:/Android/android-sdk-windows

Intro to Android Development

Setup (Live Demo! Continued)
* Install ADT Plugin for Eclipse:

* Help > Install New Software.... > Add

* https.//dl-ssl.google.com/android/eclipse/ — “ADT"

* Select All > Next > Next > Accept Terms > Finish > Restart
* Windows > Preferences... > Android

* Browse (find “android-sdk-windows” folder) > Apply > OK

* Eclipse is now ready for Android development!

Ready for your Android “Hello World™?
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http://developer.android.com/sdk/eclipse-adt.html#installing
https://dl-ssl.google.com/android/eclipse/

Intro to Android Development

oy - T

Hello World

File > New > Project >
Android > Android
Project

B New Zndroid Project l om|wl =l

New Android Project

Creates a new Android Project resource.

Project name: HelleWorld

Contents

(@ Create new project in workspace
() Create project from existing source
[¥] Use default location
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Ci/Android/workspace/HelloWorld Browse...
() Create project from existing sample
Samples: | This target has no samples. Please select another target.
Build Target
Target Name Yendor Platforrn  APIL..
Andreid 2.3 Android Open Source Project 2.3 9
Properties
Application name:  HelleAndroid
Package name: com.example.helloandroid
Create Activity:  HelloAndroid|
Min SDK Version:
@ <Back || MNea> || Fnish || Cance
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Intro to Android Development

Hello World
Add the following lines marked by “// <-----"

|J| HelloAndroid.java &7

package com.example.helloandroid;

“import android.app.Activity;
import android.o=.Bundle;
import android.widget.TextView; // <—-————-—

public cla=ss Hellofndroid extends LActivity {
J*¥% Called when the activity 1is first created.

= A0verride

super.onCreate (savedInstanceState) ;
setContentView (R.layout.main) ;

public vold onCreate (Bundle =savedInstanceState)

TextView tv = new TextView(thi=); // <————
tv.zetText ("Hello, Android"); // <————-
setContentView(twv),; 7/ <—————
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Intro to Android Development

Hello World

Run > Run > Android Application

HelloAndroid
Hello, Android
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Intro _Tg Android D

Hello World Inspection
* Package naming convention?

® M) & .

* Activity, Layout, TextView?
* R, src, res, AndroidManifest?

J| HelloAndroid.java &7

package com.example.helloandroid;:

import
import
import

public

-

android.app.bctivity:
android.os.Bundle;
android.widget .TextView; [/ <—-———-

clazs=s Hellofndroid extends Lcotivity {

J**% Called when the activity i=s first created. */
20verride

pulrlic void onCreate (Bundle s=savedInstanceState) {

saper.onCreate (savedInstanceState) ;
sectContentView (R.layout.main) ;

TextView tv = new TextView(this): // <-———-
tv.setText ("Hello, Android™),; /S <————-
setContentView(twv),; // <—-———-

evelopment

4 1= HelloWorld
4 B src
4 1 com.example.helloandroid
4 [J] HelloAndroid.java
4 O HelloAndroid
& onCreate(Bundle)
4 EI@ gen [Generated Java Files]
4 B} com.example.helloandroid
4 [J] Rjava
a Er
& attr
. & drawable
. & layout
. &f string
4 B Android 2.3

> [wd android.jar - C:\Android\andr

EI@ assets
4 22 res
> = drawable-hdpi
» = drawable-ldpi
> = drawable-mdpi
4 = layout
X mainxml
4 [ values
|X| strings.xml
2 AndroidManifest.xml
default.properties

=] proguard.cfg
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0
Intro fo Android Dlopmen’r E

Activity Cycle

* Activity = methods +

Layout + Dialogs

* Layout = Views,
Buttons, etfc.

* App = many
Activities

* Task = stack of
Activities from one
app

* Also: Services,
Broadcast
Receivers, Content
Providers

—

Liser navigales

—

onCreata()

—

onStar() -

onAasuma()

.
ity

Activity is
running

" Another aclivily comes
in Irond of the acthity

Other appfications

l
SR
l

The activily is no longer visibia

onStop)

The activity
comes o the
foreground

onResiar() | |

The activity

comes fo ihe

foreground

onDestroy()

Activity Is
shul down
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InTro To Andrmd Developmen’r
API Demos

* File > New > Projects > Android Project

* Create project from existing source
(C:\Android\android-sdk-
windows\samples\android-9\ApiDemos)

* Right click ApiDemos project > Refresh

* src > com.examples.android.apis >
ApiDemosApplication

* Run > Run > Android Application (or Ctrl+F5)

* Explore the demos!

Ready to try it yourself?
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InTro To Andrmd Development
Stopwatch 1

* Hello World, but need time and screen updating
* FormattedTime.java and RefreshHandler.java

FormattedTime

* start() - starts timer, returns “00:00:00"

* stop() - stops timer, returns time “"MM:SS:mm”
* resel() - resets timer, returns “00:00:00”

* update() - returns time "“MM:SS:mm”

RefreshHandler

* start(delay) - starts calling update() every delay ms
* stop() - stops calling update()

* update() - override this with your code

o |

-

i I
| | |-"

| — !..-'.'I I'.T.'__ + = tr.! —

1 ELT‘ e [

s

P —j—
II

ZL- ,ol.mwﬂdmud

L LOE SIIGON sddyuusd JO>:| =



Intro to Android Develobment

Stopwatch A
* Hello World,
with

Formaftted Time
and
RefreshHandler

* But this just
keeps running,
what about
stopping or
resetting”?
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package com.pennapps.stopwatch;

import
import
import

android.app.Activity.
android.o=s.Bundle;
android.widget.TextView:;
public class Stopwatch extends Activity {

private FormattedTime timer;
private TextWView TV

private RefreshTime refresh;

class BefreshTime extends RefreshHandler {
puklic wvolid update () {

tv.setText ("Time is:

ne

21

fE% Called when activity i=s first created.

@0verride

public void onCreate (Bundle savedInstanceState)
super.onCreate (savedInstanceState)
setContentView (E.lavout.ms1in) ;
TV new TextWView(this) ;
tv.8etText ("Hello, Landroid™):
setContentView (twv) ;

Cimer new FormattedTime () :
timer.start():
refresh

new RefreshTime ()
refresh.start () :

" 4+ timer.update()):
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InTro To Andrmd Development

V|ews Images and Buttons, Oh My!

. Act|V|ty setContextView(layout)
* Graphical layout — XML ‘ ‘

i

* Add in Widgets or more Views
ViewGroups:

LinearLayout, TableLayout,
RelativeLayout, ScrollView, | ..
ListView, GridView

Widgets/Content Views:
TextView, WebView,ImageView
ImageButton, Button, Checkbox, EditText, RadioButton

See Android documentation for details and more
http.//developer.android.com/quide/topics/ui/index.html
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http://developer.android.com/guide/topics/ui/index.html

InTro To Andrond Developbment

<?xml wersion="1.0" encoding="utf-8"7>

Stopwatch B

* Buttons for Start,

Stop, Reset

* Give TextView an id

for reference

* Good practice: use

strings.xml

* onClick —- method
* Use GridView or
other ViewGroups

for nicer layout

| s o T Y N TS TR ' [

3 LE3

[l e e e
1 ™y N Wb L R
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Cad Cad L R R3O ORI ORI R ORI ORD

%]

< LinearLayout

android:

android:
android:

orientation="vertical"
layout width="fi1ll parent"”
;ayD:t_hEight="fii;_parent"

tid="@g+id/time"
:;ayn:t_width="fii;_parent"
:layout height="wrap content”
rtext="gstring/h=llo"

:layout height="wrap content"”
:layout width="wrap content"
rtext="g@string/start"”
ronClick="start"

tlayout height="wrap content"”
:layout width="wrap content"
rtext="gstring/stop"
ronClick="stop™

:layout height="wrap content”
:layout width="wrap content"”
rtext="gstring/res=t"
ronClick="ras=t"

</LinearLayout>

xmlns:android="http://schema
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Intro to Android Development

Stopwatch B

* Cross-reference TextView (recast)

* onClick must be public void foo(View view)

[ ]

/*% Called when the activity i=s first created.
@0verride

public void onCreate (Bundle =savedInstanceState)

s R =

super.onCreate (savedInstanceState) ;
setContentView (R.layout.ma1in) ;
tw = (TextView) findViewById(RE.id.time):

[ TR O IS =Y

Limer = new FormattedIime () ;
Cimer.start () ;
refresh = new RefreshTime () ;

W

refresh.startci();

L R =

public void =start (View view) { timer.start():
public void stop(View view) { timer.stop():
public void reset (View view) { timer.reset():

]
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Intro to Android Development

T— — el

Stopwatch C

* Lets add unnecessary stuff!

public boolean onEevDown (int keyvCode, EeyEvent event) {
switch (kevyCode) {
case HKeyEvent.KEYCODE MENL:

AlertDialog.Builder builder = new AlertDialog.Builder (this):

builder.=setMe=ssage ("Do vou want to exit this=s ugly StopWatch?™)
2etCancelakble (fal=se)
ZetPositiveButton("Yez", new Dialoglnterface.lmClickListener|()

poblic void onClick (DialogInterface dialog, int id) {
Toast.mak=eText |

Stopwatch.this, "Goodbye!", Toast.LENGTH SHORT) .show();

Stopwatch.this.finish():

Iy
BetHegativeButton ("Ho", new Dialoglinterface.CmClickListener()
public volid onClick(DialogInterface dialog, int id) {
dialog.cancel ()

i
AlertDialog alert = builder.create():
alert.show ().
retorn troe;
defanlt:
retuorn super.onBeyDown (keyCode, ewvent):

i

|

I -_'I !|:_,.-

Pl

L_.Z

i

&

Z1-10-L L0z ‘Busg dijugd
LLOIZ 3|1qo|\ sddyuusd JO>:| >



Do you want to exit this ugly
StopWatch?

‘ Yes ‘ Mo \




Intro to Android Developmen

More Common Stuff

Graphics: http://developer.android.com/ —

* Static — XML layouts
* Active — Canvas
* 3D — OpenGL ES 1.x or 2.0 (NDK)

Audio/Video:

* Playback — MediaPlayer
* Recording — MediaRecorder

Data:

* Settings — PreferenceActivity & PreferenceManager
* Storage — External Storage, SQLite

Network:

* Connectivity — ConnectivityManager
* Locations — Uri*

Interactivity:

* Multiple activities — Intents
* Other apps/Content handling — Intent Filters

.'.

Resources Videos Blog

Reference

SDK

Home
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http://developer.android.com/

In’rro To Andrmd Developmen’r

Debugglng'

Logcat!!! (and DDMS later)

* Log.v(String tag, String msq) L

* Also Log.v, .w, .d, .wtf O

G

ADB o

* android-sdk-"/platform-tools/adb Ad
* adb push/pull/install n .}...

* adb shell

* adb logcat
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Intro o Android Development '

DDMS (Dalvik Debug Monitor Server)

* Eclipse integrated Android debugger

* Windows > Open Perspective > Other... >
DDMS

* Select device, select process

* Debug, Update Heap, Update Threads

* Allows inspection of threads, heap,
allocation, files, etc.

* Also displays Logcat and allows for
screenshots!
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m =t
Intro to Android De ZIOPH\ZIH |
| vV 1 1
® & ® ] ® . E v,
Q Devices % = O || % Threads 3 (@ Heap| (@ Allocation Tracker File Explorer |
1E |alr ] |% | o | ﬂ || D Tid Status utime stime MName e—’ j \ !
Mame 1 336 running 20309 3E86  main _-I. | g
Bl emulator-5554 Online Android2.. [| 72 338 vmwait 8 278 HeapWorker R
system_process 51 8600 3 339 vmwait 157 15 GC :
cgm.andrgid.phgne 121 2R02 *4 0 vmwait ] ] SIQHE' Catcher 1 |
jp.co.omronsoft.openwnn 117 8603 *5 341  running 119 105 JDWP B _,I | ||
com.android.launcher 126 86801 *f 342 wmwait 74 54 Compiler E\ Iy i
com.android.systemui 125 8604 7 343 native 0 0  Binder Thread #1 |
| P
android.process.media 243 8626 ] 344 native Binder Thread £2 i |
com.android.email 268 8628 T~ -
com.android.protips 284 8630 —E
com.android.quicksearchb 307 8634 Wed Jan 1205:30:52 EST 2011 1L/
oM. SVOX.pIco L 8636 Class Method File Line Native
IE com.pennapps.stopwatch 336 % (@ @63s /8700 | | .
tandroid.view View dispatchDiraw View.java 4759  false
android.view. View draw View.java 6883 false P
B Emulator Control 3 Ol android.view.ViewGr... drawChild ViewGroup java 1646 false JA
, I I
Telepheny Status o android.view ViewGr., dispatchDraw ViewGroup.java 1373 false 9‘
: || android.viewViewGr...  drawChild ViewGroup.java 1644 falze U
Voice: | home * | Speed: | Full - J |
’ ] i android.view ViewGr..  dispatchDraw ViewGroup.java 1373 falze - e =7 EE
Data: ’home '] Latency: = || android.view.View draw View.iava 6883 false 'C__31 g
LogCat 3 g_g
-]
Leg Q| @
Time pid tag Hessage <
n1i-12 0&5:29. .. I 336 dalvikvm Debugger i= active H 8
n1-12 0&5:30... I 336 dalwvikvm dvmDdmHandleHpszgChunlk{when 1, wha. . . e
01-12 05:30... D 236 dalvilkvm +++ active profiler count now 1 O @
01-12 @05:30... I 336 dalvikwm TEACE STARTED: '[DDMS]' 23192KB A lég_
n1-12 0%5:30... I &1 fActiwv. .. Process con.android. mms (pid 228). . L\ hrd
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InTro To Andrmd Developmen’r

Market and Actual Testing?

* Windows > Android SDK & AVD Manager
* Available packages > Third party Add-ons
* Google Usb Driver and Market Licensing

On your actual phone:

* MENU > Settings > Applications >
Development > USB debugging ON

* Plug in, compile and run your Android
app, select your actual phone (or might
auto-select)
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InTro To Andrmd Developmen’r

Publlshlng on the Market <———

* http://market.android.com/publish/Home =

* http://developer.android. com/guide/publishinq{pwb_Mis

* $25 one-time fee for a developer account

* Make money back via either paid app or
advertisements (AdMob)

* Compare to iOS's $99/YEAR and content
filtering/approval-based system

* Need to make sure to check support for
different screen sizes, Android OS ;
(current is 2.3 but lots still run 1.5/1.6), ’
etc. in AndroidManifest.xml file
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http://market.android.com/publish/Home
http://developer.android.com/guide/publishing/publishing.html

Intro fo Andrmd Development
Beats Advanced Rhythm Game

i Web3|te. http.://beatsportable.com

* Try it: http://www.tinyurl.com/beatspre14b

* Examples of: graphics, multi-touch,
synchronized audio, menus, settings, dialogs,

intent-filters, multiple activities, persistent data,

multi-threading, file browser, and more...

A
Keripo
i darktiger@gmai
Edit profile »
Beats. Advanced Bhythm Game (929 ¥ P W<y 116189 total Free Errors 8
v1.3b Commen ts 43330 active installs {37%)
Games: Arcade & Action
(screenshot taken Jan 12, 2011, prior to 1.4b release)

n Uploa

Published

d Application
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http://beatsportable.com/
http://www.tinyurl.com/beatspre14b

Intro to Android Development

*Useful Links/Resources

* #android-dev at freenode.irc.net
* Android Developers
http://developer.android.com/index.html
* Dev Guide = fundamentals
* Reference = Google's Javadocs
* Resources = Tips and conventions
* Blog = Newest updates, code examples
* android-developers@googlegroups.com
http.//www.mail-archive.com/android-developers@googleg
* StackOverflow — public Q&A
http.//stackoverflow.com/questions/tagged/android
* anddev.org — forums with lots of tutorials
http://www.anddev.org/
* App Inventor Beta — Google's test project
http://appinventor.googlelabs.com/about/index.html
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http://developer.android.com/index.html
http://www.mail-archive.com/android-developers@googlegroups.com/
http://stackoverflow.com/questions/tagged/android
http://www.anddev.org/
http://appinventor.googlelabs.com/about/index.html

Intro

The Joy ot Tech-.

INTRODUCING ME,
AN ANDROID
PHONE!

to Android Development

Questions? Office Hours 8-10pm, Sat. Jan 16

by Mitrozac & Snaggy

I HAVE A
TOUCH SCREEN,
ACCELEROMETER,
FULL WEB
BROWSING...

FRE-LOADED
AMAZON MP3
MUSIC STORE...

COPY AND PASTE
FUNCTIOMALITY...

PLUS ANDROID MARKET
IS FULL OF AMAZING
APPLICATIONS, OFEN TO
ALL DEVELOPERS,
WITHOUT MEDDLING.

CODDLED!

joyoftech.com
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